不喜欢Java的原因之一: JDK升级太频繁

如前所述, Java是一门优美的语言, 但是和C/C++相比, 还只不过是个新生儿, 成天的update折腾的开发人员疲于奔命, 而且很多选错方向的公司和开发人员只能放弃自己的方向和产品, sigh~

最近遇到的几个和JDK版本相关的问题是:

  1. enum: enum在JDK1.5 (即5.0)之前不是关键字, 但是5.0之后就是关键字了, 所有使用enum的1.4代码都必需修改
  2. Integer直接赋值, Integer++: 这两个Feature都是1.5之后出现的功能, 因此1.5的代码在1,4上面无法编译
  3. String类: 1.5中提供了一个contains()方法, 可以用来测试字符串是否包含某子串, 但是1.4中没有. 只好用Indexof()代替, 估计效率比较低.
  4. JDK 1.5.0_06编译的字节码在 JDK1.4.2_10上面无法运行, 估计可能是字节码的结构发生了变化.
  5. SASL包在JDK1.5中是内置的, 而1.4则不支持…

还没有折腾明白1.5的时候, Sun已经开始发布J2SESDK 6.0 Beta了, 这个动荡的世界啊~

http://java.sun.com/javase/6/

发表评论

电子邮件地址不会被公开。 必填项已用*标注